问答中心 > 电脑/网络 > 网络编程 > 如何解决IE8、IE7、IE6版本不支持HTML5标签的问题啊

如何解决IE8、IE7、IE6版本不支持HTML5标签的问题啊

1人回复
悬赏分:5 | 浏览次数:216 | 提问者:duduyu 解决时间:2014-10-27 16:07
如何解决IE8、IE7、IE6版本不支持HTML5标签的问题啊
最佳答案

HTML5新增不少比较有意思的标签,主流浏览器都支持了,包括IE9,10。
然而IE8、IE7、IE6或以下版本不支持HTML5新增标签,导致HTML5构造页面在IE8或以下显示页面混乱出错,为了兼容IE8或以下IE浏览器支持html5标签,我们可以这么解决

下载一个js插件放入网页中即可。

下载地址:http://www.gxchina.net/js/html5.js

将以下代码放入head 标签之间
<head>
<script type="text/javascript" src="http://www.gxchina.net/js/html5.js"></script>
</head>

 

0% (0)
0% (0)
目前有 0 个人评价 | 回答时间:2014-10-27 16:06

回答者: ihong | 上尉 | 采纳率:21%

擅长领域: 广信之家 设计生活

参加的活动: 暂时没有参加的活动

提问者对于答案的评价:

我来回答这个问题

回答即可得2分,回答被采纳则获得悬赏分以及奖励20分。

duduyu 班长

注册时间: 0